Get in touch
Back
Resolved

Degraded Debit Processing Times

Started 10 Jan at 04:15pm PST.

https://api.astra.finance
Created

Team Astra has implemented a solution, and is currently monitoring. We are seeing normal debit processing times now.

Posted 10 Jan at 04:15pm PST.