Back to overview
Degraded
Debit network degraded performance
Apr 04 at 01:00pm PDT
Affected services
https://api.astra.finance
Resolved
Apr 04 at 03:20pm PDT
Our banking partner implemented a fix at 2:55pm PDT. We're seeing debit activity return to normal and will continue to monitor the situation.
Affected services
Updated
Apr 04 at 02:06pm PDT
Our banking partner has identified the root cause and is actively working toward a resolution.
Affected services
Created
Apr 04 at 01:00pm PDT
We're seeing a slight increase in debit failures over the past half hour.
This is due to an issue with the debit networks. We are actively working with our banking partner to mitigate.
Affected services