AWS Outage
Resolved
Oct 20 at 02:17pm PDT
Service functionality has been restored, pending transfers are being processed, and we are continuing to monitor service health.
Affected services
Updated
Oct 20 at 01:24pm PDT
AWS has applied additional mitigation steps, and they are seeing gradual recovery across services. We have confirmed services are still impacted, and are continuing to work on a fix for this issue.
Affected services
Updated
Oct 20 at 12:25pm PDT
AWS has applied additional mitigation steps. We are continuing to work on a fix for this issue.
Affected services
Updated
Oct 20 at 11:25am PDT
AWS has applied additional mitigation steps. We are continuing to work on a fix for this issue.
Affected services
Updated
Oct 20 at 10:05am PDT
AWS has applied mitigation steps. We are continuing to work on a fix for this issue.
Affected services
Created
Oct 20 at 09:00am PDT
The global AWS outage is affecting debit services including adding cards and processing transfers involving debit rails. We are working with our partners to resolve the issue.
Affected services